指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  均线  短线  趋势  

通达信入场时间主图指标公式源码

时间:2019-11-21 09:06 来源:股窜网 作者:gucuan 阅读:
通达信入场时间主图指标公式
通达信入场时间主图指标公式
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.008,0,所属板块),COLORWHITE;
HDC:=(14,81,28);
R1:=HHV(H,HDC);
R2:=LLV(L,HDC);
R3:=(R1-R2)/R2*100<15;
R4:=HHV(H,20)<=REF(HHV(H,20),9) AND LLV(L,20)>=REF(LLV(L,20),9);
R5:=HHV(H,20)<=REF(HHV(H,10),19) AND LLV(L,20)>=REF(LLV(L,10),19);
RBH:=R3*R4*R5 AND REFX(C>REF(R1,1),1);
FH1:=BARSNEXT(RBH);
FH2:=REFX(R1,FH1);
FH3:=REFX(R2,FH1);
FH4:=MIN(BARSLAST(H>FH2 AND FH1>29),BARSLAST(L<FH3 AND FH1>29));
FH5:=REFX(FH4,FH1);
STICKLINE(FH1<FH5 AND FH1>0,FH2,FH3,8,0),COLORAA0055;
STICKLINE(FH1<FH5 AND FH1>0,FH2,FH2,80,0),COLOR00FFFF;
STICKLINE(FH1<FH5 AND FH1>0,FH3,FH3,8,0),COLOR00FFFF;
XG:=RBH,COLORRED,NODRAW;
DRAWICON(RBH,H*1.02,7);
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(C/REF(C,1)>=1.095 AND H=C,O,C,1.5,0),COLORRED;
势线上轨:=10;
势线下轨:=10;
AA:=REF(H,势线上轨)=HHV(H,2*势线上轨+1);
AA1:=REF(L,势线下轨)=LLV(L,2*势线下轨+1);
QY:=BACKSET(AA,势线上轨+1);
QY1:=BACKSET(AA1,势线下轨+1);
CC:=FILTER(QY,势线上轨) AND H=HHV(H,势线上轨+1);
CC1:=FILTER(QY1,势线下轨) AND L=LLV(L,势线下轨+1);
DDD:=BARSLAST(CC);
DD1:=BARSLAST(CC1);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
GDCS1:=CONST(DINGBUTS);
DDCS1:=CONST(DDTS1);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
H11:=CONST(REF(HIGH,DINGBUTS1-1)),COLOR888888;
H22:=CONST(REF(HIGH,GDCS1-1)),COLOR888888;
GDCS23:=H11;
GDCS13:=H22;
DDTS2:=REF(DDTS1,DD1+1);
L1:=CONST(REF(L,DDTS2-1));
L2:=CONST(REF(L,DDCS1-1));
压力:BACKSET(ISLASTBAR,GDCS1),COLORFF7766,NODRAW;
支撑:BACKSET(ISLASTBAR,DDCS1),COLOR6699FF,NODRAW;
STICKLINE(压力,GDCS13,GDCS13,3.0,1),COLORFF7766;
STICKLINE(支撑,L2,L2,3.0,1),COLOR6699FF;
MA05:=MA(C,5);
五日乖离率:=(C-MA05)/MA05*100;
五日乖离:=ISLASTBAR=1 AND 五日乖离率>6;
DRAWTEXT_FIX(五日乖离=1 ,0.83,0.20,0,'五日乖离>6 '),COLORFFFFAA;
{十战七胜}
CA3:=(C-LLV(L,7))/(HHV(H,7)-LLV(L,7))*100;
CA4:=SMA(CA3,3,1);
CA5:=SMA(CA4,3,1);
CA6:=3*CA4-2*CA5;
CA7:=C-REF(C,1);
CA8:=100*EMA(EMA(CA7,6),6)/EMA(EMA(ABS(CA7),6),6);
买:=LLV(CA8,2)=LLV(CA8,7) AND COUNT(CA8<0,2) AND CROSS(CA8,MA(CA8,2));
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;
{九转序列}
AB1:=C>REF(C,4);
AB2:=BARSLASTCOUNT(AB1);
AB3:=REF(AB2,1)=8 AND AB2>REF(AB2,1);
AB4:=REF(BETWEEN(AB2,5,8),1) AND AB2<REF(AB2,1);
AB5:=ISLASTBAR AND BETWEEN(AB2,6,8);
AB6:=(BACKSET(AB3>0,9) OR BACKSET(AB4>0,AB2+1)*0 OR BACKSET(AB5>0,AB2))*AB2;
DRAWTEXT(AB6>0,H+H*0.02,VAR2STR(AB6,0)),COLORFF00FF{COLOR00FFFF};
DRAWTEXT(AB2=9,H+H*0.02,'9'),COLOR00FF00;
BA1:=C<REF(C,4);
BA2:=BARSLASTCOUNT(BA1);
BA3:=REF(BA2,1)=8 AND BA2>REF(BA2,1);
BA4:=REF(BETWEEN(BA2,5,8),1) AND BA2<REF(BA2,1);
BA5:=ISLASTBAR AND BETWEEN(BA2,6,8);
BA6:=(BACKSET(BA3>0,9) OR BACKSET(BA4>0,BA2+1)*0 OR BACKSET(BA5>0,BA2))*BA2;
DRAWTEXT(BA6>0,L-L*0.02,VAR2STR(BA6,0)),COLOR00FF00{COLORFFFFFF};
DRAWTEXT(BA2=9,L-L*0.02,'9'),COLORFF00FF;
{MOS量化}
DIFF:=100*(EMA(CLOSE,12)-EMA(CLOSE,26)),NODRAW;
DEA:=EMA(DIFF,9),NODRAW;
MACD:=(DIFF-DEA)*2,NODRAW;
死叉:=CROSS(DEA,DIFF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(LOW,N1+1);
DIFL1:=LLV(DIFF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIFF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIFF/POW(10,PDIFL3));
{股窜网 www.gucuan.com}
直接底部结构:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND DIFF<0 AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,0);
隔峰底部结构:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,0);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底部结构,2)) OR ((MDIFB3>REF(MDIFB3,2))*REF(隔峰底部结构,2)),NODRAW;
P:=CROSS(DIFF,DEA);
DRAWTEXT(FILTER(BG AND P,MACD>0),L*0.99,'●底部结构'),COLORMAGENTA;
金叉:=CROSS(DIFF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(HIGH,M1+1);
DIFH1:=HHV(DIFF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIFF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIFF/POW(10,PDIFH3));
直接顶部结构:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND DIFF>0 AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,0);
隔峰顶部结构:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,0);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶部结构,2)) OR ((MDIFT3<REF(MDIFT3,2))*REF(隔峰顶部结构,2)),NODRAW;
Q:=CROSS(DEA,DIFF);
DRAWTEXT(FILTER(TG AND Q,MACD<0),H*1.02,'顶部结构'),COLORGREEN;
W1:=FILTER(IF(HHVBARS(HIGH,13),0,1),13);
DRAWTEXT(W1 AND PERIOD=5,H*1.01,'时间'),COLORYELLOW;
W2:=FILTER(IF(LLVBARS(LOW,13),0,1),13);
DRAWTEXT(W2 AND PERIOD=5,H*1.01,'时间'),COLORYELLOW;
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(NT=9,H*1.007,'高点'),COLORGREEN;
K1:=REF(C,0)>REF(C,13);
K2:=REF(NT=9,13);
DRAWTEXT(K1 AND K2 AND PERIOD=5,H*1.007,'顶'),COLORRED;
B1:=C;
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(NT0=9,L*0.994,'低点'),COLORRED;
T1:=REF(C,0);
T2:=REF(NT0=9,13);
DRAWTEXT(T1 AND T2 AND PERIOD=5,L*0.994,'底'),COLORGREEN;
A1A:=EMA(CLOSE, 9);
A1B:=((A1A - EMA(CLOSE, 5)) < 0);
A1C:=((A1A - EMA(CLOSE, 5)) > 0);
A1D:=BARSLAST(A1B);
A1E:=BARSLAST(A1C);
A1F:=IF((A1E > 0),(CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,0);
A20:=SUM(A1F,0);
A21:=IF((A1D > 0),(0 - 2),0);
A22:=IF((A1E > 0),SUM((CLOSE - REF(CLOSE, 1)) / REF(CLOSE, 1) * 100,A1E),0);
A23:=A22 / A1E;
A25:=EMA(EMA(EMA(CLOSE, 3), 3), 3);
上升通道:((A25 - REF(A25, 1)) + A25),COLORYELLOW;
反转通道:MA(上升通道, 15),COLORGREEN;
DRAWTEXT(CROSS(C,反转通道)AND PERIOD=5,L*0.994,'↑多头'),COLORFF00FF;
DRAWTEXT(CROSS(反转通道,C)AND PERIOD=5,H*1.01,'↓空头'),COLORGREEN;
通道上:EMA(CLOSE,45) + 2*STD(CLOSE,45) ,COLORFF00FF,DOTLINE,LINETHICK1;
通道下:EMA(CLOSE,45) - 2*STD(CLOSE,45) ,COLORFF00FF,DOTLINE,LINETHICK1;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-