指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  缠论

通达信副图指标:成交量主力,看真正的主力资金

时间:2021-03-15 14:59 来源:股窜网 作者:gucuan 阅读:
成交量主力
个股的资金情况,特别是主力资金的情况.这是通达信软件的真正的主力资金情况,需要L2数据。
如没收费L2行情,可以在本周搜索下载一个最新版开心果版本即可。
0轴以上,红色柱表示的是主力买入量,蓝色住是主力的卖出量;0轴以下,红色柱是主力的净买量,绿色柱是主力的净卖量。希望得到点赞。

副图源码如下:
{成交量主力,通达信副图}
万手:VOL/10000,LINETHICK0;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
预测:AA/10000;

主力买量:(L2_VOL(0,0)+L2_VOL(1,0))/10000,COLORRED,NODRAW;
主力卖量:(L2_VOL(0,1)+L2_VOL(1,1))/10000,COLORLIBLUE,NODRAW;
主力买:=L2_VOL(0,0)+L2_VOL(1,0);
主力卖:=L2_VOL(0,1)+L2_VOL(1,1);
散户买量:=L2_VOL(2,0)+L2_VOL(3,0);
散户卖量:=L2_VOL(2,1)+L2_VOL(3,1);
主力净量:(主力买量-主力卖量),COLORRED,NODRAW;
散户净量:(散户买量-散户卖量)/10000,COLORMAGENTA,NODRAW;
主力净:=主力买-主力卖;
{散户净:=散户买量-散户卖量;}
{股窜网 WWW.GUCUAN.COM 整理}
持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORLIBLUE;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;
对应上涨家:INDEXADV,COLOR0080FF,NODRAW;
对应下跌家:INDEXDEC,COLORGREEN,NODRAW;

换手率:VOL/CAPITAL*100,NODRAW,COLORRED;

STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,1),COLORWHITE;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,1),COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,1),COLORGREEN;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLOR00FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR007777 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR009999 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00BBBB ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR00DDEE ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.2 , 0 ) , COLORFFFFFF ;

STICKLINE(主力卖>=0,0,主力卖,3.2,0),COLOR990000;
STICKLINE(主力卖>=0,0,主力卖,2.7,0),COLORCC0000;
STICKLINE(主力卖>=0,0,主力卖,2.1,0),COLORFF4400;
STICKLINE(主力卖<=0,0,主力卖,1.5,0),COLORFF8800;
STICKLINE(主力卖>=0,0,主力卖,0.9,0),COLORFFCC00;
STICKLINE(主力卖>=0,0,主力卖,0.2,0),COLORCYAN;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,3.2,0),COLOR000033;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,2.7,0),COLOR000066;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,2.1,0),COLOR000099;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,1.5,0),COLOR0000CC;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,0.9,0),COLOR0000FF;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,0.2,0),COLORCC66FF;

STICKLINE(主力净<=0,0,主力净,3.2,0),COLOR003300;
STICKLINE(主力净<=0,0,主力净,2.7,0),COLOR006600;
STICKLINE(主力净<=0,0,主力净,2.1,0),COLOR009900;
STICKLINE(主力净<=0,0,主力净,1.5,0),COLOR00CC00;
STICKLINE(主力净<=0,0,主力净,0.9,0),COLOR00FF00;
STICKLINE(主力净<=0,0,主力净,0.2,0),COLORGREEN;

STICKLINE(主力净>=0,0,-主力净,3.2,0),COLOR000033;
STICKLINE(主力净>=0,0,-主力净,2.7,0),COLOR000066;
STICKLINE(主力净>=0,0,-主力净,2.1,0),COLOR000099;
STICKLINE(主力净>=0,0,-主力净,1.5,0),COLOR0000CC;
STICKLINE(主力净>=0,0,-主力净,0.9,0),COLOR0000FF;
STICKLINE(主力净>=0,0,-主力净,0.2,0),COLORCC66FF;
0; 
五日: MA(V,5),COLOR40FF00;
三五日: MA(V,35),COLORYELLOW;
一三五日:MA(V,135),COLOR0080FF;
NOTEXT强:IF(五日>MA(五日,2),五日,DRAWNULL),COLORRED;
{股窜网 WWW.GUCUAN.COM 整理}
{昨收:REF(CLOSE,1),NODRAW,COLORGREEN;
逐笔买卖差:(LARGEINTRDVOL-LARGEOUTTRDVOL)/10000,COLORBROWN,NODRAW;
主动买卖差:(ACTINVOL-ACTOUTVOL)/10000,COLORBROWN,NODRAW;}
超B:L2_AMO(0,0)/10000.0,NODRAW;
大B:L2_AMO(1,0)/10000.0,NODRAW;
超S:L2_AMO(0,1)/10000.0,NODRAW;
大S:L2_AMO(1,1)/10000.0,NODRAW;
主力净值:(超B+大B)-(超S+大S),NODRAW;
DAZHI:CONST(MAX(ABS(主力净值),MAX(ABS(超B),MAX(ABS(大B),MAX(ABS(超S),ABS(大S)))))),NODRAW;

DRAWRECTREL(0,0,175,999.4,IF(120,RGB(10,0,0),0));
DRAWRECTREL(0,CONST(830-(ABS(主力净值)*500/DAZHI)),30,935,IF(CONST(主力净值)>0,RGB(255,0,255),RGB(0,100,100)));
DRAWRECTREL(35,CONST(830-(ABS(超B)*500/DAZHI)),65,935,IF(CONST(超B)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(70,CONST(830-(ABS(超S)*500/DAZHI)),100,935,IF(CONST(超S)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(105,CONST(830-(ABS(大B)*500/DAZHI)),135,935,IF(CONST(大B)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(140,CONST(830-(ABS(大S)*500/DAZHI)),170,935,IF(CONST(大S)>0,RGB(100,0,0),RGB(0,50,0)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.000,0.95,0,'净值'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.038,0.95,0,'超B'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0764,0.95,0,'超S'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.112,0.95,0,'大B'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.147,0.95,0,'大S'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'今日主力买卖'),COLORYELLOW;{原为:今日分类持仓}
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.100,0,0,'单位(万元)'),COLORYELLOW;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.00,0.875,0,INTPART(主力净值)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.035,0.800,0,INTPART(超B)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.070,0.875,0,INTPART(超S)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.105,0.800,0,INTPART(大B)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.140,0.874,0,INTPART(大S)),COLORYELLOW;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-