指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  均线  盘口  短线  趋势  

通达信改布林轨道主图指标公式源码

时间:2019-06-19 10:14 来源:股窜网 作者:gucuan 阅读:
股窜网(www.gucuan.com)提醒您,以下是:通达信改布林轨道主图指标公式
通达信改布林轨道主图指标公式源码
M:=20;
{涨停变色}
CA:=REF(C,1);
涨停1:=IF((C-CA)*100/CA>=(10-0.01*100/CA),1,0);
STICKLINE(涨停1,OPEN,CLOSE,2,0),COLORYELLOW;
跌停:=IF((CA-C)*100/CA>=(10-0.01*100/CA),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORBLUE;
BOLL:MA(CLOSE,M);
IF(BOLL>=REF(BOLL,1),BOLL,DRAWNULL),COLORRED;
IF(BOLL<REF(BOLL,1),BOLL,DRAWNULL),COLORGREEN,LINETHICK2;
UB:BOLL+2*STD(CLOSE,M)COLORYELLOW;
LB:BOLL-2*STD(CLOSE,M)COLORMAGENTA;
MA5:MA(C,5)COLORWHITE,LINETHICK1;
IF(C>=MA(C,5),MA(C,5),DRAWNULL),COLOR9933DD,LINETHICK2;
X1:=(C+L+H)/1.5;
X2:=EMA(X1,3);
X3:=EMA(X2,2.5);
DRAWICON(CROSS(X2,X3),L*0.98,9),COLORRED;
昨日中轨:=REF(C,1)>BOLL;
回踩中轨:=(L-BOLL)/L<=0.01 AND (L-BOLL)/L>=-0.01 AND C>BOLL AND C>O;
中轨连涨:=UPNDAY(BOLL,3);
回踩布林中轨:=回踩中轨 AND 昨日中轨 AND 中轨连涨,COLORLIRED;
DRAWICON(回踩布林中轨,L*0.995,41);
收口:=(UB-LB)/LB<=0.25;
上穿轨道:=CROSS(C,BOLL) OR CROSS(C,UB);
中轨向上:=BOLL>REF(BOLL,1) OR BOLL=REF(BOLL,1);
布林收口选股:=收口 AND 上穿轨道 AND 中轨向上;
DRAWICON(布林收口选股,L*0.985,23);
昨日上轨:=REF(CROSS(C,UB),1);
回踩上轨:=(L-UB)/L<=0.01 AND (L-UB)/L>=-0.01 AND C>UB AND C>L;
回踩上轨选股:=昨日上轨 AND 回踩上轨;
DRAWICON(回踩上轨选股,L*0.975,33);
{临界点}
UP1:=23;
UPPER:(1+UP1/100)*MA(CLOSE,25),COLOR404088,LINETHICK2;
{东方不败箭头}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWICON(VAR19,L*0.98,30);
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-