指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  缠论

密集压力线主图指标源码

时间:2021-06-01 06:47 来源:股窜网 作者:gucuan 阅读:
压力线越密集的区域,股价面临的突破压力越大,根据常见图形,一般到密集压力线位置,股价横幅震荡具多。

周期:CURRBARSCOUNT,NODRAW,COLORGREEN;
N:=1;
N1:=100;
N2:=3;
N3:=1;
N4:=1;
N5:=1;
N6:=1;
N7:=1;
N8:=0;
N9:=0;
N10:=0;
N11:=0;
N12:=2;
CXG:=HHV(HIGH,N)=HHV(HIGH,0) AND BARSCOUNT(CLOSE)>=N;
T:=BARSLAST(CXG);
TJ:=CROSS(REF(L,T),C);
DRAWLINE(CXG,REF(H,T),REF(CXG,1),REF(REF(H,T),1),1),DOTLINE,COLORWHITE;
X_1:=REFX(HHV(MAX(OPEN,CLOSE),N1),周期-1);
X_2:=REFX(LLV(LOW,N1),周期-1);
X_3:=CLOSE/REF(CLOSE,3)<=1-N2/100 AND OPEN>CLOSE;
均五:IF(N9>0,MA(CLOSE,5),DRAWNULL),COLORWHITE;
均十:IF(N10>0,MA(CLOSE,10),DRAWNULL),COLORYELLOW;
均二十:IF(N11>0,MA(CLOSE,20),DRAWNULL),COLORMAGENTA;
X_4:=IF(N12=1,0.5,IF(N12=2,1,IF(N12=3,(-1),IF(N12=4,3,4))));
X_5:=0;
X_6:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1)),周期-1);
X_7:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_6)),周期-1);
X_8:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_7)),周期-1);
X_9:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_8)),周期-1);
X_10:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_9)),周期-1);
X_11:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_10)),周期-1);
X_12:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_11)),周期-1);
X_13:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_12)),周期-1);
X_14:=REFX(REF(OPEN,BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_13)),周期-1);
X_15:=REFX(BARSLAST(X_3 AND OPEN<X_1),周期-1)+1;
X_16:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_6),周期-1)+1;
X_17:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_7),周期-1)+1;
X_18:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_8),周期-1)+1;
X_19:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_9),周期-1)+1;
X_20:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_10),周期-1)+1;
X_21:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_11),周期-1)+1;
X_22:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_12),周期-1)+1;
X_23:=REFX(BARSLAST(X_3 AND OPEN<X_1 AND OPEN>X_13),周期-1)+1;
X_24:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_6,X_15-周期)=0);
X_25:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_7,X_16-周期)=0);
X_26:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_8,X_17-周期)=0);
X_27:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_9,X_18-周期)=0);
X_28:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_10,X_19-周期)=0);
X_29:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_11,X_20-周期)=0);
X_30:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_12,X_21-周期)=0);
X_31:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_13,X_22-周期)=0);
X_32:=IF(N3=1,1,COUNT(MAX(OPEN,CLOSE)>X_14,X_23-周期)=0);
STICKLINE(周期<X_15 AND X_24,X_6,X_6,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_16 AND X_25,X_7,X_7,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_17 AND X_26,X_8,X_8,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_18 AND X_27,X_9,X_9,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_19 AND X_28,X_10,X_10,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_20 AND X_29,X_11,X_11,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_21 AND X_30,X_12,X_12,X_4,X_5),COLORLIGREEN;
STICKLINE(周期<X_22 AND X_31,X_13,X_13,X_4,X_5),COLORLIBLUE;
STICKLINE(周期<X_23 AND X_32,X_14,X_14,X_4,X_5),COLORLIGREEN;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-