指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  

江恩八线+精品指标+绝佳买点+交叉见底+绝密波段 通达信指标公式

时间:2019-03-19 12:24 来源:股窜网 作者:gucuan 阅读:
江恩八线+精品指标+绝佳买点+交叉见底+绝密波段 通达信指标公式

江恩八线(主图)
大盘:=EMA(INDEXC,500)/EMA(C,500);
大盘线:=INDEXC/大盘,LINETHICK1,COLORBLUE;
工作线:EMA(C,14),COLOR00FFFF,LINETHICK1;
一号线:EMA(CLOSE,144),POINTDOT,LINETHICK2,COLOR0000FF;
二号线:EMA(C,25),COLORWHITE,LINETHICK2;
三号线:EMA(C,318),COLOR0000FF,LINETHICK2;
四黑马线:EMA(C,453),CIRCLEDOT,LINETHICK1,COLOR428899;
五号线:EMA(C,550),COLORFFCC66;
六号线:EMA(C,610),LINETHICK2,COLORYELLOW;
七号线:EMA(C,730),COLORBLUE;
八号线:EMA(C,99),POINTDOT,LINETHICK2,COLORWHITE;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),COLORWHITE;
DEA:=EMA(DIFF,9),COLORF00FF0 ;
MACD:=0.90*(DIFF-DEA), COLORSTICK;
TJ:=(DIFF>=DEA);
TJ1:=(DIFF>=0);
{STICKLINE(TJ,H,L,0,0),COLORYELLOW;}
STICKLINE(TJ,O,C,3,1),COLORYELLOW;
STICKLINE(TJ1 AND TJ,H,L,0,0),COLORF00FF0;
STICKLINE(TJ1 AND TJ,O,C,3,1),COLORF00FF0;
STICKLINE(DIFF<DEA,H,L,0,0),COLORF0F000;
STICKLINE(DIFF<DEA,O,C,3,0),COLORF0F000;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(VAR1,13)-EMA(VAR1,73);
SD:= EMA(SK,2);
{DRAWTEXT((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) ,L*0.99,'短线'),COLORRED;}
{STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),H,L,0,0),COLORRED;}
STICKLINE((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)),O,C,3,0),LINETHICK3,COLORRED;
SS:=CROSS(二号线,八号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(二号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(二号线,一号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98{AND CROSS(二号线,三号线)};
DRAWICON(SS,L-0.04,1);
DD:=CROSS(八号线,一号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(八号线,四黑马线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(八号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98
OR CROSS(八号线,三号线) AND C>1.5 AND C>REF(C,1.5) AND C/REF(C,1.5)>=0.98 AND CROSS(二号线,四黑马线);
{DD:=CROSS(二号线,四黑马线);};

精品指标(幅图)
{【精品指标】}
VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;
VAR5:=SMA(VAR4,3,1);
【阳】: SMA(VAR5,3,1),COLORRED,LINETHICK2;
Y1:=SMA(【阳】,3,1);
VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;
【阴】: SMA(VAR6,3,1),COLORYELLOW,LINETHICK2;
Y2:=SMA(【阴】,3,1);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;
VARC:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;
VARD:=CLOSE*100/MA(CLOSE,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VARE<-10,-10,VARE);
VAR10:=IF(VARC>10,10,VARC);
VAR11:=IF(VAR10<-10,-10,VAR10);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR14:=INDEXC;
VAR15:=REF(VAR14,1);
VAR16:=100*(VAR14-VAR15)/VAR14;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(INDEXC,1);
VAR24:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)
VAR25:=ZIG(3,10)REF(ZIG(3,10),2);
VAR26:=MA(CLOSE,26);
VAR27:=VAR26+2*STD(VAR3,26);
VAR28:=VAR26-2*STD(VAR3,26);
VAR29:=VAR26+2*STD(REF(VAR3,1),26);
VAR2A:=VAR26-2*STD(REF(VAR3,1),26);
VAR2B:=IF(VAR24 AND VAR1
VAR2C:=IF(VAR25*VAR1 AND VAR2>VAR27,2,VAR2B);
VAR2D:=IF(VAR2C=1,80,45);
VAR2E:=IF(VAR2C=2,0,VAR2D);
VAR2F:=VAR2E;
D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,5,0),COLOR0055AA;
STICKLINE(D1
{STICKLINE(D1>=REF(D1,1),D1,D2,2,0),COLOR0077CC;}
STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR0099DD;
{STICKLINE(D1
STICKLINE(D1
【强弱】:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100;
DRAWTEXT(ISLASTBAR=1 AND (CROSS(【强弱】,Y2) OR VAR2E>45),80,' 短期吃货!'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND (CROSS(Y1,【强弱】) OR VAR2E<45),80,' 短期出货!'),COLORGREEN;
DRAWTEXT(ISLASTBAR=1 AND VAR17>VAR18,60,' 个股强于大盘!'),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1 AND VAR12>VARF,50,' 大盘处在下降通道'),COLORCCFF99;
DRAWTEXT(ISLASTBAR=1 AND VAR18>=VAR17,60,' 个股弱于大盘!'),COLOR00FFFF;
DRAWTEXT(ISLASTBAR=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待涨!'),COLOR0099FF;
DRAWTEXT(ISLASTBAR=1 AND VAR1AVAR1E AND NOT(CROSS(【强弱】,20)),40,' 下调减持!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND VAR1D<=VAR1E,40,' 盘整阶段!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1F)/VAR1F>0.035,40,'出现井喷行情!'),COLORRED;

绝佳买点(幅图)
VAR2:=(HIGH+LOW+(CLOSE)*(2))/(4);
BH:=((EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))*(38)),COLOR0000FF,LINESTICK;
BL:=((((-1))*(EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))+0.01)*(38)),COLOR339999,LINESTICK;
VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VAR33:=EMA(VAR22,10);
VAR44:=EMA(VAR33,10);
VAR55:=(3)*(VAR33)-(2)*(VAR44);
VAR66:=EMA(VAR55,5);
桥:(EMA(VAR66,1)),COLORYELLOW,LINETHICK1;
跨:(REVERSE(桥)),COLORFFFFFF,LINETHICK1;
{(0),COLORFFFF00,LINETHICK3;}
趋势:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))
/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);
底部:=5;
DRAWTEXT(CROSS((趋势),底部),15,'◆底部'),COLORYELLOW;
{DRAWTEXT(CROSS(趋势,底部),0,'▲'),COLORYELLOW;
DRAWTEXT(CROSS(趋势,底部),20,'●'),COLORYELLOW;}
VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3))
AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2))
AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))
AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR (REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));
VARA2:=LLV(LOW,5);
VARA3:=HHV(HIGH,5);
VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),1);
VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);
VARA6:=(VARA5<24) AND (OPEN
STICKLINE(VARA1 AND (VARA6),-40,40,10,1),COLOR2894FF;
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
趋势1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)
*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
探底:IF((趋势<=5),58,0),COLORFF00FF;
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);
STICKLINE((美化),-20,20,15,1),COLORFFFF00;
MTM1:MA((CLOSE-REF(CLOSE,13))*31,5),LINETHICK2,COLOR7711EE;
VARF1:=MA(HHV(HIGH,485),17);
VARF2:=MA(HHV(HIGH,222),17);
VARF3:=MA(HHV(HIGH,96),17);
VARF4:=MA(LLV(LOW,485),17);
VARF5:=MA(LLV(LOW,222),17);
VARF6:=MA(LLV(LOW,96),17);
VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);
VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);
VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);
VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);
VARFB:=IF(C=C,VARFA,VARFA*DAY);
VARFC:=LOW;
VARFD:=REF(LOW,1);
VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;
VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);
VARF10:=LLV(LOW,30);
VARF11:=HHV(VARFF,30);
绝佳买点:IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),100000000)/(200),COLORRED,LINETHICK2;
I:=IF(CLOSE
骤雨初晴:=ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
W:=COST(10)*0;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORRED;
DEA:=EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA)*231,STICK,COLORRED,LINETHICK1;
STICKLINE(MACD0,0,MACD,0.9,0),COLOR00FFFF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.8,0 ),COLORFFEE44;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORFF55BB;
DRAWTEXT(CROSS(绝佳买点,1.20000) ,-32,'买点'),COLORYELLOW,LINETHICK2 ;
DRAWTEXT(CROSS(绝佳买点,4.50000) ,63,'●'),COLORYELLOW,LINETHICK2;
{DRAWTEXT(CROSS(绝佳买点,7.00000) ,88,'↑'),COLORYELLOW,LINETHICK4;}
DRAWTEXT(CROSS(绝佳买点,3.60000) ,28,'↑'),COLORYELLOW,LINETHICK4;
{DRAWTEXT(CROSS(绝佳买点,2.40000) ,-55,'↑'),COLORYELLOW,LINETHICK3 ; };

交叉见底
XX:=((((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34)) * 100)* 5);
B001:=(((((CLOSE - MA(CLOSE,42)) / MA(CLOSE,42)) ) * 100) * 5);
B002:=(((((CLOSE - MA(CLOSE,67)) / MA(CLOSE,67)) ) * 100) * 5);
B003:=(((XX + B001) / 2) - (B002 ));
B004:=(((0 - 100) * (HHV(HIGH,34) - CLOSE)) / (HHV(HIGH,34) - LLV(LOW,34)));
B005:=(((0 - 100) * (HHV(HIGH,42) - CLOSE)) / (HHV(HIGH,42) - LLV(LOW,42)));
B006:=(((0 - 100) * (HHV(HIGH,72) - CLOSE)) / (HHV(HIGH,72) - LLV(LOW,72)));
B007:=EMA((((B004 + B005) / 2) - B006),6);
B008:=REF(CLOSE,1);
B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) * 1.25);
B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) * 1.25);
B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) * 1.25);
B012:=EMA(((((B009 + B010) / 2) - B011) * 5),6);
B013:=((((0 - 1) * ((B007 + B003) + B012)) / 3) * 1.5);
B014:=B012;
B015:=B013;
B016:=EMA(B012,4);
B017:=B012;
KKM1:=B013;
DPM1:=EMA(B013,4);
多头:B017,COLOR0000FF;
空头:KKM1,COLOR00FF00;
多均:B016;
空均:DPM1;
B018:=IF(CROSS(B017,KKM1),28,0);
XD:5 ;
VARX:=B017;
C023:=KKM1;
C024:=B016;
C025:=DPM1;
C026:=WINNER(CLOSE);
W:=(DMA(C026,((VOL / CAPITAL) * 1)) * 100);
HWXWINNER:=W;
XD1:=EMA(W,6);
XWXMH:=XD1;
XD2:=MA(W,14);
庄家控盘:((HWXWINNER - XWXMH) * 10),COLORSTICK,LINETHICK2;
STICKLINE(CROSS(多头,空均),0,50,8,0) ,COLORRED;

绝密波段(幅图)
VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波: VAR3;
段: VAR4;
VAR6:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR6,10)=1,40,'抄底'),LINETHICK3  ;
STICKLINE(FILTER(VAR6,10)=1,0,30,10,0),COLORGREEN  ;
VAR7:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR7,5)=1,80,100,10,0),COLORYELLOW  ;
DRAWTEXT(FILTER(VAR7,5)=1,70,'逃顶'),LINETHICK3 ,COLORYELLOW;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
STICKLINE(VAR8,85,100,10,0) ;
90 ;
0;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-