指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  

通达信公式:黄金分割主图(源码 、主图 、通达信 、 贴图)杨凯

时间:2019-02-12 10:56 来源:股窜网 作者:gucuan 阅读:
为了能将杨凯老师的黄金分割主图能让更多人使用,特改为通达信版,方便大家综合判断!
指标简单说明:
1、主图中的黄金分割图按杨凯老师的定义编制;
2、图中变色均线为20日均线,上涨浪下跌浪一目了然,方便看盘;
3、指标不是万能的,只是一个参考工具!详细使用请参考杨凯老师的黄金分割课程;

我学到了很多思路和方法,在这里向各位老师表示感谢并祝节日快乐!!!
本指标的未来函数是划线函数,不影响判断,大家放心使用。
黄金分割主图(源码 、主图 、通达信 、 贴图)杨凯高级课
实收价:=IF((FRACPART((C * 100)) > 0.46),(CEILING((C * 100)) / 100),(FLOOR((C * 100)) / 100));
柒%阳:=(实收价 >= IF((FRACPART(((REF(实收价,1) * 1.07) * 100)) > 0.46),(CEILING(((REF(实收价,1) * 1.07) * 100)) / 100),(FLOOR(((REF(实收价,1) * 1.07) * 100)) / 100)));
涨停:=(实收价 >= IF((FRACPART(((REF(实收价,1) * 1.1) * 100)) > 0.46),(CEILING(((REF(实收价,1) * 1.1) * 100)) / 100),(FLOOR(((REF(实收价,1) * 1.1) * 100)) / 100)));
跌停:=(实收价 <= IF((FRACPART(((REF(实收价,1) * 0.9) * 100)) > 0.46),(CEILING(((REF(实收价,1) * 0.9) * 100)) / 100),(FLOOR(((REF(实收价,1) * 0.9) * 100)) / 100)));
二十均线:=(INTPART((MA(C,20) * 100)) / 100);
站稳状态:=(SUM((C >= 二十均线),4) = 4);
跌破状态:=(SUM((C <= 二十均线),4) = 4);
站稳确立:=CROSS(站稳状态,0.5);
跌破确立:=CROSS(跌破状态,0.5);
上涨浪:=((((BARSLAST(站稳确立) < BARSLAST(跌破确立)) && (BARSLAST(站稳确立) >= 0)) ||
((BARSLAST(跌破确立) = -(1)) && (BARSLAST(站稳确立) >= 0))) || (((BARSLAST(跌破确立) = -(1)) && (BARSLAST(站稳确立) = -(1))) && (C > 二十均线)));
下跌浪:=((((BARSLAST(跌破确立) < BARSLAST(站稳确立)) && (BARSLAST(跌破确立) >= 0))
|| ((BARSLAST(站稳确立) = -(1)) && (BARSLAST(跌破确立) >= 0))) || (((BARSLAST(跌破确立) = -(1)) && (BARSLAST(站稳确立) = -(1))) && (C <二十均线)));

SJS:=IF(DATE<=130170917,1,0);{均线时间限制函数30-09-17}
MA5:IF(SJS>0,(INTPART((MA(CLOSE,5) * 100)) / 100),0)COLORWHITE,LINETHICK2;
MA10:=IF(SJS>0,(INTPART((MA(CLOSE,10) * 100)) / 100),0)COLORYELLOW,DOTLINE;
MA20:IF(SJS>0,(INTPART((MA(CLOSE,20) * 100)) / 100),0)COLORRED,LINETHICK2;
MA250:MA(CLOSE,250)DOTLINE;

稳:=CROSS(上涨浪,0.5);
破:=CROSS(下跌浪,0.5);
稳日:=BARSLAST(CROSS(上涨浪,0.5));
破日:=BARSLAST(CROSS(下跌浪,0.5));
站稳:=IF(上涨浪,(稳日 + 1),(-(破日) - 1)),COLORYELLOW,LINETHICK0;
不破20日:=((站稳 > 0) && (站稳状态 = 1));

T1:=BARSLAST((稳 = 1));
T2:=BARSLAST((破 = 1));
低点点:=IF((T1 = 0),LLV(L,(T2 + 8)),0);
高点点:=IF((T2 = 0),HHV(H,(T1 + 8)),0);
低收点点:=IF((T1 = 0),LLV(C,(T2 + 8)),0);
高收点点:=IF((T2 = 0),HHV(C,(T1 + 8)),0);
低点黄:=IF((T2 > T1),REF(SUM(低点点,(T1 + 1)),(T1 + 1)),SUM(低点点,(T1 + 1)));
高点原:=SUM(高点点,(T2 + 1));
低点原:=SUM(低点点,(T1 + 1));
SJS1:=DATE > 1300917;
低点:=IF(SJS1,0,IF(((FRACPART((低点黄 * 100)) * 10) > 4.6),(CEILING((低点黄 * 100)) / 100),(INTPART((低点黄 * 100)) / 100))),COLORYELLOW,NODRAW;
STICKLINE(CURRBARSCOUNT=13,低点,低点,700,1),COLORYELLOW;

%1:=IF(SJS1,0,IF(((FRACPART((高点原 * 100)) * 10) > 4.6),(CEILING((高点原 * 100)) / 100),(INTPART((高点原 * 100)) / 100))),COLORYELLOW,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%1,%1,700,1),COLORYELLOW;

%0.382:=(INTPART(((低点 + ((%1 - 低点) * 0.382)) * 100)) / 100),COLORGREEN,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%0.382,%0.382,700,1),COLORGREEN;

%0.618:=(INTPART(((低点 + ((%1 - 低点) * 0.61803)) * 100)) / 100),COLORMAGENTA,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%0.618,%0.618,700,1),COLORMAGENTA;

%1.618:=(INTPART(((低点 + ((%1 - 低点) * 1.61803)) * 100)) / 100),COLORRED,NODRAW;
STICKLINE(CURRBARSCOUNT=13,%1.618,%1.618,700,1),COLORRED;

TT:=BACKSET(BARSTATUS=2 , 2);
TTT:=FILTER(TT ,3);

DRAWTEXT(TTT,%1,'%1'),COLORYELLOW;        
DRAWTEXT(TTT,%0.382,'%0.382'),COLORGREEN;    
DRAWTEXT(TTT,%0.618,'%0.618'),COLORMAGENTA;    
DRAWTEXT(TTT,低点,'低点'),COLORYELLOW;         
DRAWTEXT(TTT,%1.618,'%1.618'),COLORRED;

T1T:=BACKSET(BARSTATUS=2 , 20);
TT1T:=FILTER(T1T ,21);
DRAWNUMBER(TT1T,%1.618,%1.618),COLORRED;
DRAWNUMBER(TT1T,低点*0.015+低点,低点),COLORYELLOW;
DRAWNUMBER(TT1T,%0.618,%0.618),COLORMAGENTA;
DRAWNUMBER(TT1T,%0.382,%0.382),COLORGREEN;
DRAWNUMBER(TT1T,%1,%1),COLORYELLOW;
IF(上涨浪 AND SJS>0,MA20,DRAWNULL),LINETHICK2,COLORRED;
IF(下跌浪 AND SJS>0,MA20,DRAWNULL),LINETHICK2,COLORGREEN;

推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-