指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  

通达信极绝顶底主图指标公式源码

时间:2019-08-29 13:33 来源:股窜网 作者:gucuan 阅读:
以下内容是股窜网(www.gucuan.com)为你提供的:通达信极绝顶底主图指标公式源码
通达信极绝顶底主图指标公式
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
盈损线:EMA(CLOSE,17),COLORWHITE;
强弱线:EMA(X,13),COLORRED;
生命线:EMA(KKC,50),COLORYELLOW;
行情线:=EMA(A,1);
N:=90;M:=3;
海底:REF(LLV(L,N),M)NODRAW,COLORLIMAGENTA;
低:=REF(LLV(L,N),M);
低点:=REFDATE(低,DATE);
绝底:=低点=L AND ((C-L)>(0-C) OR (O-L)>(C-O));
STICKLINE(绝底,C,O,3,0),COLORMAGENTA;
STICKLINE(绝底,L,H,0.1,0),COLORMAGENTA;
DRAWTEXT(绝底,L*0.97,'---绝底')COLORYELLOW;
{DRAWICON(CROSS(行情线,强弱转换线),L*0.95,7);
DRAWICON(FILTER(行情线/止盈止损线>1.06,15),H*1.02,8);}
DRAWICON(CROSS(74,RSI),HIGH*1.01,8);
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWICON(FILTER(买=1,7),LOW*0.95,7);
VARC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWTEXT(CROSS(84,VARC),H*1.02,'---顶'),COLORGREEN;
日:=150;
昨前:=3;
高1:=REF(HHV(H,日),昨前);
天顶:REFDATE(高1,DATE)NODRAW,COLORCYAN;
顶:=REFDATE(高1,DATE);
极顶:=REFDATE(顶,DATE);
跑:=极顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O));
STICKLINE(跑,C,O,3,0),COLORGREEN;
STICKLINE(跑,L,H,0.1,0),COLORGREEN;
DRAWTEXT(跑,H*1.01,'---绝顶')COLORGREEN;
DRAWTEXT_FIX(1,0,0.02,0,'生命线上操作')COLORYELLOW;
DRAWTEXT_FIX(1,0,0.06,0,'突破盈损线买')COLORWHITE;
DRAWTEXT_FIX(1,0,0.10,0,'跌破盈损线卖')COLORLIRED;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-