指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  均线  盘口  短线  趋势  

通达信真正的波段幅图指标公式

时间:2019-04-29 20:18 来源:股窜网 作者:gucuan 阅读:
通达信真正的波段幅图指标公式
{吸筹}
A1P:=REF(CLOSE,2);
A2P:=SMA(MAX(CLOSE-A1P,0),7,1)/SMA(ABS(CLOSE-A1P),7,1)*100;
A4P:=REF(LOW,1);
A5P:=SMA(ABS(LOW-A4P),3,1)/SMA(MAX(LOW-A4P,0),3,1)*100;
A6P:=EMA(IF(CLOSE*1.3,A5P*10,A5P/10),3);
A7P:=LLV(LOW,29);
A8P:=HHV(A6P,37);
A9P:=IF(MA(CLOSE,90),1,0);
A10P:=EMA(IF(LOW<=A7P,(A6P+A8P*2)/2,0),3)/1688*A9P;
A11P:=IF(A10P>100,100,A10P);
STICKLINE(A11P,0,A11P,4,1),COLOR666666;
VAR1:=MA(CLOSE,27);
VAR2:=(CLOSE-VAR1)/VAR1*100;
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
VARA:=MA(VAR2,2);
VARB:=BARSLAST(CROSS(-10,VARA)=1);
VARC:=BARSLAST(CROSS(VARA,10)=1);
VARD:=VARA<-10 AND VARB>3;
VARE:=VARA>10 AND VARC>3;
短线:SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR009900;
中线:SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED;
中长线:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));
长线:SMA(RSV3,5,1),COLORYELLOW;
看底:STICKLINE(中线<15,中线,15,6,0),COLORF00FF0;
黄金:STICKLINE(短线<20 AND 中线<20 AND 长线<20,MAX(长线,MAX(短线,中线)),20,3,0),COLOR00CCFF;
看顶:STICKLINE(中线>80,80,中线,3,0),COLORFFF000;
DR:=IF(COUNT(CROSS(中长线,-90),12)=3,30,5);
KH1:=IF(VARD,VARA,0);
KH2:=REF(KH1,1)<0;
DRAWICON(CROSS(长线,15),中线,1);
DRAWTEXT(LONGCROSS(中线,20,15),20,'反弹');
DRAWTEXT(CROSS(短线,长线)AND 长线<18 AND 长线>REF(长线,1)OR CROSS(长线,5),20,'绝佳机会'),COLOR00BBBB;
底:DRAWTEXT(CROSS(中长线,-90) AND (长线<中线 AND 长线>REF(长线,1)OR 短线<20 AND 中线<20 AND 长线 <20),长线,'底'),COLORFF00FF;
{波段轨道}
TC1:=IF(H=HHV(H,48),H,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=H))+1;
UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
BC1:=IF(L=LLV(L,48),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;{低点定位}
HP:=CURRBARSCOUNT<=TC2 AND H=UPPER;{高点定位}
DRAWTEXT(LP,40,'↖波段底'),COLORLIGREEN;{波段底文字提示}
DRAWTEXT(HP,89,'波段顶'),COLORMAGENTA;{波段顶文字提示};
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-