指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 技术指标 > KDJ指标 >
热门搜索: 黑马王子  盘口  均线  短线  趋势  

通达信KDJ多周期金叉主图指标公式源码

时间:2019-11-20 10:35 来源:股窜网 作者:gucuan 阅读:
通达信KDJ多周期金叉主图指标公式
通达信KDJ多周期金叉主图指标公式
MA20:MA(C,20),COLORRED,LINETHICK2;
MA55:MA(C,55),COLOR00FF00,LINETHICK2;
IF(MA20<REF(MA20,1),MA20,DRAWNULL),COLORFF0000,LINETHICK2;
IF(MA55<REF(MA55,1),MA55,DRAWNULL),COLORFFFF00,LINETHICK2;
BB:MA(MA(CLOSE,3),1),LINETHICK3,COLOR00FFFF;
IF(BB>=REF(BB,1),BB,DRAWNULL),COLORFF00FF,LINETHICK3;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AA:=最低3;
周J:=MA("KDJ.J#WEEK"(9,3,3) ,5),COLORFFFF00,LINETHICK2;
AA1:=周J<0 AND 周J<REF(周J,1) ;
FF1:=周J<0 AND 周J>REF(周J,1);
BB1:=周J>=0 AND 周J<85 AND 周J>REF(周J,1);
DD1:=周J>=REF(周J,1) AND 周J>=85 ;
EE1:=周J<REF(周J,1) AND 周J>0;
ZJ1:=MA("KDJ.J#WEEK"(9,3,3) ,5);
YK:=MA("KDJ.K#MONTH"(9,3,3),20),LINETHICK0;
YD:=MA("KDJ.D#MONTH"(9,3,3),20),LINETHICK0;
YJ:=MA("KDJ.J#MONTH"(9,3,3),20);
ZK:=MA("KDJ.K#WEEK"(9,3,3) ,5),LINETHICK0;
ZD:=MA("KDJ.D#WEEK"(9,3,3) ,5),LINETHICK0;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),LINETHICK0;
D:=SMA(K,3,1),LINETHICK0;
J:=3*K-2*D,LINETHICK0;
GG1:=C>0;
RJC:DRAWICON(CROSS(K,D),L*0.98,1);
DRAWTEXT(RJC,L*0.98,'日金叉'),COLOR0000FF;
RSC:DRAWICON(CROSS(D,K),H*1.03,2),;
DRAWTEXT(RSC,H*1.03,'日死叉'),COLORFFFFFF;
ZJC: DRAWICON (CROSS(ZK,ZD), L*0.98,1);
DRAWTEXT(ZJC,L*0.98,'周金叉'),COLORFF00FF;
ZSC: DRAWICON (CROSS(ZD,ZK), H*1.03,2),;
DRAWTEXT(ZSC,H*1.03,'周死叉'),COLOR00FFFF;
YJC: DRAWICON (CROSS(YK,YD), L*0.98,1);
DRAWTEXT(YJC,L*0.98,'月金叉'),COLORFF0000;
YSC: DRAWICON (CROSS(YD,YK), H*1.03,2),;
DRAWTEXT(YSC,H*1.03,'月死叉'),COLORFFFF00;
STICKLINE(AA1,AA-0.000*AA,AA-0.040*AA,2.5,1),COLOR6600BB;
STICKLINE(FF1,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR0000FF;
STICKLINE(BB1,AA-0.000*AA,AA-0.040*AA,2.5,0),COLORFF00FF;
STICKLINE(DD1,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR00FF00;
STICKLINE(EE1,AA-0.000*AA,AA-0.040*AA,2.5,1),COLORFFFF00;
STICKLINE(GG1,AA-0.050*AA,AA-0.090*AA,2.5,1),COLORBB0000;
STICKLINE(RJC,AA-0.050*AA,AA-0.090*AA,2.5,0),COLOR0000FF;
STICKLINE(RSC,AA-0.050*AA,AA-0.090*AA,2.5,0),COLORFFFFFF;
STICKLINE(ZJC,AA-0.050*AA,AA-0.090*AA,2.5,0),COLORFF00FF;
STICKLINE(ZSC,AA-0.050*AA,AA-0.090*AA,2.5,0),COLOR00FFFF;
STICKLINE(YJC,AA-0.050*AA,AA-0.090*AA,2.5,0),COLORFF0000;
STICKLINE(YSC,AA-0.050*AA,AA-0.090*AA,2.5,0),COLORFFFF00;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-