指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  

通达信金钻变色MACD+RSI+KDJ指标公式

时间:2020-07-02 18:06 来源:股窜网 作者:gucuan 阅读:
通达信金钻变色MACD+RSI+KDJ指标公式
通达信金钻变色MACD+RSI+KDJ指标公式
金钻MACD源码:
DIF:EMA(CLOSE,3)-EMA(CLOSE,7);
DEA:EMA(DIF,3);
MACD:(DIF),COLORSTICK;
DIF,COLORGREEN,LINETHICK2;
DEA,COLORGREEN,LINETHICK2;
线上金叉买:0,COLORGREEN,LINETHICK2;
IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWICON(CROSS(DIF,DEA),DEA,25);
DRAWICON(CROSS(DEA,DIF),DEA,24);

KDJ买入源码
VAR1:=(H+L+O+C*2)/5;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,23);
VAR4:=EMA(VAR1,2);
VARA:=(VAR1-VAR2)*100/VAR3;
K:(EMA(VARA,23)+100)/2-3,COLOR00FFFF,LINETHICK2;
D:SMA(K,5,1),COLORFFFF00,LINETHICK2;
J:4*K-3*D,COLORFF00FF,LINETHICK2;
IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
IF(J<REF(J,1),J,DRAWNULL)COLOR00BB00,LINETHICK2;
DRAWICON(FILTER(J>REF(J,1)AND J<REF(J,3)
AND J<K AND VAR4>REF(VAR4,1)
AND K>=REF(K,1)AND J<40
OR CROSS(J,K)AND CROSS(J,D)
AND J<40 OR J>REF(J,1)AND J<-20,7), J*0.8,1);
DRAWICON(FILTER(J<=REF(J,1) AND J>80,8), J*1.2,2);

RSI变色源码:
LC:=REF(CLOSE,1);
RSI6:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,LINETHICK2;
MA6 :MA(RSI6,6),COLORGREEN;
IF(MA6>REF(MA6,1) OR RSI6>MA6,MA6,DRAWNULL),COLORRED,LINETHICK2;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-