指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  

通达信经典指标标准macd顶背离提示主副图选股公式源码

时间:2020-06-29 22:51 来源:股窜网 作者:gucuan 阅读:
之所以说是标准顶背离,是因为在我看来网上能看到的关于macd顶背离、底背离的帖子里,关于顶背离和底背离的写法基本上都有瑕疵。且慢这话不是为了拉仇恨,或者是污蔑或者贬低别人。慢慢往下看解释就是。
你可以文明的留言来质疑
网上能看到的顶背离写法大部分都是依照快线或者macd红柱最高那一天去对应的找股价的高。或者是根据macd死叉那一天的收盘价和前一个死叉那一天的收盘价去比对价格高低。上面三种写法都存在瑕疵,有些错的还不是一般的大。这种依照快线最高、或者macd红柱最高那一天去找价最高,往往是写指标的人的一厢情愿认定,是的有好多票符合快线数值最大的那一天股价也创了新高,或者macd红柱最大的那一天股价也创了新高。可是那毕竟是一部分票符合这样的规律,有好多票在快线或者红柱创新高的那一天,估计未必同步创了新高。(macd快线值最大那一天不一定股价那一天就创新高,macd红柱值最大的那一天不一定股价也是创新高的)。这就是问题所在。别急我会上图,图上我对快线高点和红柱最高做了特殊标记,相对于的K线那一天也做了特殊标记。明眼人一看就明白。至于根据死叉那一天来和前死叉那一天收盘价对比高低就更不严谨了。会出现很多问题。
不在赘述,直接上图。你们自己看。有不同意见可以文明发声留言。我也想借机来提高自己的认知。
特别提示一下我写的顶背离有三大要素,股价这次创了新高,但是macd快线、红柱值和前一波macd快线、红柱比都未创新高。且这一波红柱数量和前一波红柱比较少了。线背、柱背、时背。
通达信经典指标标准macd顶背离提示主副图选股公式源码

通达信经典指标标准macd顶背离提示主副图选股公式源码

标准macd顶背离选股源码

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD1:=(DIFF-DEA)*2;
JT1:=(BARSLAST(CROSS(DIFF,DEA)));
JT2:=(SUMBARS(CROSS(DIFF,DEA),2)-1);
ST1:=(BARSLAST(CROSS(DEA,DIFF)));
ST2:=(SUMBARS(CROSS(DEA,DIFF),2)-1);
JZX1:=HHV(DIFF,JT1)<>HHV(DIFF,JT2) AND HHV(MACD1,JT1)<>HHV(MACD1,JT2);
JZX2:=HHV(H,JT1)=HHV(H,JT2);
JZX3:=JT1<(JT2-ST2);
XG: DIFF>0 AND CROSS(DEA,DIFF) AND JZX1 AND JZX2 AND JZX3;

顶背离主图文字提示
此段源码放在你的k线主图里,可以看到顶背离提示


DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD1:=(DIFF-DEA)*2;
JT1:=(BARSLAST(CROSS(DIFF,DEA)));
JT2:=(SUMBARS(CROSS(DIFF,DEA),2)-1);
ST1:=(BARSLAST(CROSS(DEA,DIFF)));
ST2:=(SUMBARS(CROSS(DEA,DIFF),2)-1);
JZX11:=HHV(DIFF,JT1)<>HHV(DIFF,JT2) AND HHV(MACD1,JT1)<>HHV(MACD1,JT2);
JZX22:=HHV(H,JT1)=HHV(H,JT2);
JZX33:=JT1<(JT2-ST2);
XG:=DIFF>0 AND CROSS(DEA,DIFF) AND JZX11 AND JZX22 AND JZX33;
DRAWTEXT(XG,H,'顶背')COLORYELLOW;

推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-