指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信指标 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  盘口  短线  均线  趋势  

超级神奇BOLL 通达信指标

时间:2020-05-24 17:57 来源:股窜网 作者:gucuan 阅读:
超级神奇BOLL
超级神奇BOLL
N:=20;
MID:=MA(C,N);
VART1:=POW((C-MID),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:REF(MID,1),COLORFFFFFF;
上升:IF(BOLL>REF(BOLL,1),BOLL,DRAWNULL),COLORRED,LINETHICK2;
下降:IF(BOLL<REF(BOLL,1),BOLL,DRAWNULL),COLORGREEN,LINETHICK2;
UB:REF(UPPER,1),COLOR00FFFF;
LB:REF(LOWER,1),COLORFF00FF;
X_1:=VOL/CAPITAL;
X_2:=IF(DATE<1181230 AND DATE>900101,1,0);
X_3:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
X_4:=2.8*MAX(X_1,X_3);
X_5:=DMA(CLOSE,X_4);
X_6:=20*(X_5/REF(X_5,1)-1)*38;
X_7:=EMA(X_6,2);
X_8:=EMA(X_6,2);
X_9:=EMA(X_8,2);
X_10:=EMA(X_8,8);
X_11:=1.1*(MAX(INDEXH,REF(INDEXC,1))/MIN(INDEXL,REF(INDEXC,1))-1);
X_12:=2.5*MAX(X_1,X_11);
X_13:=DMA(INDEXC,X_12);
X_14:=EMA(20*(X_13/REF(X_13,1)-1),1)*38;
X_15:=EMA(X_14,2);
X_16:=EMA(X_14,3);
STICKLINE( MA(CLOSE,60)>MA(CLOSE,120),MA(CLOSE,60),MA(CLOSE,120),8,0),RGB(221,160,221);
STICKLINE( MA(CLOSE,60)<MA(CLOSE,120),MA(CLOSE,60),MA(CLOSE,120),8,0),RGB(152,251,152);
DRAWKLINE(H,O,L,C);
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★底部')
,LINETHICK2,COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'★高位');
VAR1:=ZIG(3,13);
STICKLINE((REF(VAR1,2) < REF(VAR1,1)) AND (VAR1 < REF(VAR1,1)),
CLOSE,OPEN,3,0),COLORBLUE;
DRAWICON(CROSS(REF(ZIG(3,12),1),ZIG(3,12)),HIGH*1.02,2);
STICKLINE((REF(VAR1,2) > REF(VAR1,1)) AND (VAR1 >REF(VAR1,1)),
CLOSE,OPEN,3,0),COLORYELLOW;
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.99,1);
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED,NODRAW;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORBLUE,NODRAW;
ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,DOTLINE,COLORGREEN,NODRAW;
ZD2:EMA(ZD1,25),LINETHICK2,NODRAW;
DRAWBAND(ZD1,RGB(55,0,0),ZD2,RGB(0,91,0)),NODRAW;
DRAWKLINE(H,O,L,C),NODRAW;
STICKLINE(ZD1>LOW AND ZD1<HIGH,ZD1,MIN(MIN(OPEN,CLOSE),ZD1),2,0),COLORYELLOW;
STICKLINE(ZD1>MIN(C,O) AND ZD1<MAX(C,O),ZD1,MIN(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,HIGH,LOW,0,0),COLORYELLOW;
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
DRAWTEXT_FIX(1,0.2,0.1,0,STRCAT('【涨停原因】',EXTERNSTR(0,888))),COLORYELLOW;
{黄色}
CIN:=MIN(REF(CLOSE,2),REF(CLOSE,1));
{STICKLINE(VAR1AMZ,CIN,O,3,0),COLOR00AAFF;
STICKLINE(VAR1AMZ,CIN,O,2,0),COLOR00CCFF;
STICKLINE(VAR1AMZ,CIN,O,1,0),COLOR00EEFF};
牛节点:=CROSS(EMA(C,5),EMA(C,30))AND CROSS(EMA(C,10),EMA(C,20));
DRAWICON(牛节点,L*0.99,25);
CSAR:=SAR(10,2,20);
持股:=IF(CSAR<=L,CSAR,0),CIRCLEDOT,COLORRED{持股};
短期趋势:=EMA(SLOPE(C,21)*20+C,42),POINTDOT,LINETHICK1,COLORYELLOW;
STICKLINE(1,短期趋势,短期趋势,1,0),COLORYELLOW,NODRAW;
止损:=EMA(C,5),COLORYELLOW,LINETHICK1;
VVAR1D:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);
短底:=EMA(VVAR1D,5);
支撑:=HHV(短底,60);
MAN:=(SMA(HIGH,21,2) * 1.05);
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
中D:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);
X1D:=EMA(中D,10);
RSVD:=SMA(下档线,3,1);
K大:=SMA(RSVD,3,1);
D大:=((3 * RSVD) - (2 * K大));
J12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(J12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力位:=IF(CROSS(D24,D大),HIGH,REF(HIGH,BARSLAST(CROSS(D24,D大)))),COLORFFFFFF;
{STICKLINE(ISLASTBAR,ZC1,ZC1,120,0),LINETHICK1,COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=15,ZC1*1.02,'关键价位'),COLORGREEN;
DRAWNUMBER(ISLASTBAR,ZC1*1.02,ZC1+000),COLORGREEN;
STICKLINE(ISLASTBAR,ZC2,ZC2,120,0),LINETHICK1,COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=15,ZC2*0.99,'支撑价位'),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,ZC2*0.99,ZC2+000),COLORYELLOW};
决策:=IF(ISLASTBAR,压力位,DRAWNULL),COLORMAGENTA;
{STICKLINE(ISLASTBAR ,决策,决策,60,1),LINETHICK3,COLORFFFFFF};
底部:=LLV(HIGH,30),COLOR00FF00;
超跌:=IF(ISLASTBAR,底部,DRAWNULL),COLORRED;
{STICKLINE(ISLASTBAR ,超跌,超跌,60,1),LINETHICK3,COLORRED;
STICKLINE(ISLASTBAR,REF(今重心,1),REF(今重心,1),10,0),COLORGREEN};
{顶底信号}
{LC:=REF(C,1);
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
逃命:=CROSS(80,RSI5);
DRAWICON(逃命,H*1.005,15);
TJ1:=REF("CCI.CCI",1)>90  AND "CCI.CCI"<REF("CCI.CCI",1);
TJ2:=REF("KDJ.J"(9,3,3),1)>90 AND "KDJ.J"(9,3,3)<REF( "KDJ.J"(9,3,3),1);
TJ3:=REF("RSI.RSI1",1)>70 AND "RSI.RSI1"<REF("RSI.RSI1",1);
TJ4:=COUNT(TJ1,5) AND COUNT(TJ2,5) AND COUNT(TJ3,5);
大顶:=CROSS(TJ4,0.5);
DRAWTEXT(大顶,H*1.01,'顶');
TJ5:=REF("CCI.CCI",1)<-100  AND "CCI.CCI">REF("CCI.CCI",1);
TJ6:=REF("KDJ.J"(9,3,3),1)<20 AND "KDJ.J"(9,3,3)>REF( "KDJ.J"(9,3,3),1);
TJ7:=REF("RSI.RSI1",1)<20 AND "RSI.RSI1">REF("RSI.RSI1",1);
TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);
大底:=CROSS(TJ8,0.5);
DRAWTEXT(大底,L*0.991,'底');}
{涨停标注}
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
{涨停天数}
VARZT:=BARSLAST(C/REF(C,1)>1.094);
DRAWTEXT(VARZT=2,L*0.95,'3T'),COLORWHITE;
DRAWTEXT(VARZT=4,H*1.06,'5T'),COLORWHITE;
DRAWTEXT(VARZT=7,L*0.95,'8T'),COLORWHITE;
DRAWTEXT(VARZT=12,H*1.06,'13T'),COLORWHITE;
DRAWTEXT(VARZT=20,L*0.95,'21T'),COLORWHITE;
DRAWTEXT(VARZT=33,H*1.03,'34T'),COLORWHITE;
DRAWTEXT(VARZT=54,L*0.95,'55T'),COLORWHITE;
DRAWTEXT(VARZT=88,H*1.06,'89T'),COLORWHITE;
DRAWTEXT(VARZT=143,L*0.95,'144T'),COLORWHITE;
DRAWTEXT(VARZT=232,H*1.06,'233T'),COLORWHITE;
DRAWTEXT(VARZT=376,L*0.95,'377T'),COLORWHITE;
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-