指标大全 移动平均线 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖离率 SAR 威廉指标 宝塔线 | 股票公式 通达信 同花顺 飞狐 东方财富 大智慧 股票书籍下载
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
赞助商广告
当前位置股窜网 > 指标公式 > 通达信公式 >
热门搜索: 黑马王子  均线  盘口  短线  趋势  

通达信KDJ神物指标公式源码

时间:2019-09-05 11:05 来源:股窜网 作者:gucuan 阅读:
通达信KDJ神物指标公式
{
用法
1.导弹发射车下方的蓝色柱体逐渐变短时,可以买入;
2.如果趋势已经较为明显了,并出现红箭头,可以加仓。
3.紫色线是雷达,白色柱体是发射车,彩色柱体是导弹;
4.导弹车的大小与MACD的蓝色柱体有关,蓝色柱体越大,导弹车越大;
5.发射车的长度越大,一般威力越大;
6.导弹发射车下方的蓝色柱体逐渐变短时,可以买入;
7.如果趋势已经较为明显了,并出现红色箭头,可以加仓。
}
{主力进场}
VAR11:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR22:=SMA(ABS(LOW-VAR11),13,1)/SMA(MAX(LOW-VAR11,0),10,1);
VAR33:=EMA(VAR22,10);
VAR44:=LLV(LOW,33);
VAR55:=EMA(IF(LOW<=VAR44,VAR33,0),3);
主力进场:STICKLINE(VAR55>REF(VAR55,1),0,VAR55,3,0 ),COLORFF00FF;
洗盘:STICKLINE(VAR55<REF(VAR55,1),0,VAR55,3,0),COLORGREEN;
{火箭发射}
VAR1:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
提醒:STICKLINE(VAR6<=-6,0,-25,5,0),COLOR88B7EA;
关注:STICKLINE(VAR6<=-8,5,25,7,0),COLORWHITE;
{MACD:VAR6*5,COLORSTICK,LINETHICK2;}
出击:STICKLINE(VAR6<=-10,80,100,5,0),COLORYELLOW;
警戒雷达:IF(VAR6<-6,21,0),LINETHICK3,COLORFF0099;
引导雷达:STICKLINE(VAR6<=-10,65,35,4,0);
K:SMA(VAR1,3,1),COLORWHITE,LINETHICK1;
D:SMA(K,5,1),COLORYELLOW,LINETHICK1;
J:3*K-2*D,COLORMAGENTA,LINETHICK2;
制导雷达:STICKLINE(VAR6<=-10,40,0,4,0),COLORRED;
底:20,LINETHICK1,COLORCYAN;
{入顶:80,LINETHICK1,COLORCYAN;}
走强:50,LINETHICK1,COLORWHITE,DOTLINE;
大顶:100,LINETHICK1,COLORGREEN;
发射:STICKLINE(VAR6<=-10,80,30,3,0),COLORGREEN;
导弹:STICKLINE(VAR6<=-10,80,60,3,0),COLORWHITE;
XG:CROSS(底,警戒雷达);
DRAWICON(XG,警戒雷达+15,1);
{顶底背离}
L1:= H=HHV(H,20); D1:= BARSLAST(L1);
L2:= L1 AND J<REF(J,REF(D1,1)+1);
L3:= L=LLV(L,20); D2:= BARSLAST(L3);
L4:= L3 AND J>REF(J,REF(D2,1)+1);
DRAWTEXT(L2,J,'↓顶'),COLORGREEN;
{DRAWTEXT(L4,J,'↑底'),COLORRED;}
DRAWICON(L4,J,11);
DRAWLINE(L2,J,L4 AND BARSLAST(L2)<20,J,0),COLORRED,LINETHICK3;
{我爱涨停板}
RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
KK:=SMA(RSV,2,1);
DD:=SMA(KK,2,1);
JJ:=3*KK-2*DD;
RS:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
F:=100;
K1:=RS>=100;
K2:=RS<100;
DRAWICON(CROSS(K1,K2),K1,25);
{选股公式}
{
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
警戒雷达:=IF(VAR6<-6,21,0),LINETHICK3;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
GHM:=REF(MACD,1)<REF(MACD,2) && MACD>REF(MACD,1);
XG:GHM AND 警戒雷达=21;
};


通达信公式源码导入和使用方法    
推荐图文

Copyright @ GuCuan.com 股窜网 版权所有 免责声明:本站所发表的内容仅用于学术交流,内容所带来的一切后果均与本站无关。 若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

温馨提示:本站不从事任何收费业务,如遇到以此名义收费,请提高警惕,谨防上当受骗! 本站所有信息免费,所有广告和涉及链接,与股窜网均无任何关系,请股友自行判断真假。

豫ICP备14026518号-1 下载帮助-关于本站-版权声明-联系我们- 隐私条款-